TRIMBLE TSC7 CONTROLLER AND TRIMBLE T7 TABLET: DUAL MODEM IN DEVICE MANAGER CAUSING CELLULAR CONNECTION ISSUES
Overview
Two WWAN drivers are shown in the Device Manager which may cause cellular connection issues in the Trimble® TSC7 Controller and the Trimble T7 Tablet:
In devices with the issue, the Cellular button (as shown in the image below) cannot be enabled.
Potential Causes
In SOME cases, this may be a Microsoft® OS bug and there are documented work-arounds on the web, see Microsoft Support here. It could also be caused if the radio is turned off. In the bottom right corner of the login screen there is a radio button that can be used to turn the radio on and off. Trimble has also identified a root cause for the 'dual-modem' problem and has a set of resolutions in place that are available now.
The Sierra™ modem EM7430 used in both the Trimble TSC7 Controller and the Trimble T7 Tablet is configured to present multiple USB interfaces to the PC host and requires a driver for use in Windows® 10 devices. When the TSC7 / T7 controllers launched we implemented a step in our (Trimble) production process to reconfigure the modems to present a single USB interface, compatible with Windows 10, which did not require a driver.
However, this reconfiguration process was not compatible with the software environment used in the Service Operations. To maintain compatibility, we decided not to reconfigure modems, and to install a driver in the OS. Thus, OS B25-T/GB10-T includes the driver for the Sierra modem. This change was implemented on the production lines in June 2019.
Unfortunately, the information we had on the modems did not indicate that the default USB configuration was to present two network interfaces to the PC. The modems in the early-production devices do not not present two network interfaces.
Solution
With support from Sierra Wireless we have determined the correct USB configuration to use and have created a Graphical User Interface (GUI) end user field update tool with a link and instructions below. Trimble has fixed this issue in production, and reworked all inventory to configure the modems correctly and remove one of the network interfaces. Devices shipped before June 1st , 2019 or after August 15th, 2019 will not be affected by this issue. A GUI update tool is available for all TSC7 / T7 users. The tool is intended only for customers who experience the dual-modem issue, although it will not have any negative side effects if run on devices that don't exhibit the problem.

NOTE: If the tool is run on a device that went through our production process before June 2019 it will report 'No modem found' as the configuration applied to those devices did not instantiate a 'modem' interface.
To use the tool:
- Download the zip archive from the following link http://dl.trimble.com/mcs/tsc7_yuma7_modemupdate.zip.
- Extract (unzip) the file to the device or a USB stick. There are two files in the archive.
- Run the program 'ModemUsbConfig.exe'.
- Click the 'Update Modem' button.
- Observe progress...it only takes a few seconds.
- Click 'Close' when it's done.
Affected Units
This support note applies to all TSC7 and T7 WWAN SKUs.
PLEASE ONLY RUN IF YOUR UNIT HAS BEEN AFFECTED.
More Information
For more information, contact your Trimble regional account manager